import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:\\buser1\\b)?(.+?)(?:\\buser1\\b|$)";
final String string = "I don't get how to create a regular expression that matches everything, except a fixed, single word. Can somebody help me?\n\n"
+ "Background: alias map for mailserver which redirects all mail to one user. /.*/ -> user1 produces a redirection loop, so i need to exclude user1 from the regexp.\n\n"
+ "Edit:\n\n"
+ "The regex should match everything, EXCEPT the single word user1. It should also match input that contains that word, i.e., user11.\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}