const regex = /(?:\buser1\b)?(.+?)(?:\buser1\b|$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:\\buser1\\b)?(.+?)(?:\\buser1\\b|$)', 'gm')
const str = `I don't get how to create a regular expression that matches everything, except a fixed, single word. Can somebody help me?
Background: alias map for mailserver which redirects all mail to one user. /.*/ -> user1 produces a redirection loop, so i need to exclude user1 from the regexp.
Edit:
The regex should match everything, EXCEPT the single word user1. It should also match input that contains that word, i.e., user11.
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}