#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "~^"
Local $sString = "Lorem ipsum dolor sit amet, consectetur adipiscing elit." & @CRLF & _
"Nullam sit amet neque vitae mi lobortis bibendum luctus at orci." & @CRLF & _
"Maecenas sit amet felis ultrices, imperdiet nibh et, laoreet nisl." & @CRLF & _
"Etiam nec ligula ac quam cursus rhoncus." & @CRLF & _
"Duis ac purus id massa malesuada dapibus." & @CRLF & _
"Quisque tempor sapien sit amet blandit interdum." & @CRLF & _
"Sed sed libero non enim posuere pretium." & @CRLF & _
"Cras in nisl sed magna vestibulum ultrices." & @CRLF & _
"Sed eget neque sodales, porttitor magna nec, facilisis dolor." & @CRLF & _
"Donec venenatis tortor nec leo viverra, non fermentum nulla pulvinar." & @CRLF & _
"Pellentesque a nulla laoreet, euismod lectus vel, porta erat." & @CRLF & _
"Fusce at justo in massa blandit lacinia nec maximus nulla." & @CRLF & _
"Nam vulputate risus et sem facilisis lobortis." & @CRLF & _
"Integer vel risus et enim tempor iaculis." & @CRLF & _
"Pellentesque at nibh in ipsum sagittis congue." & @CRLF & _
"Nam ullamcorper nibh sit amet felis bibendum, congue tincidunt nibh cursus." & @CRLF & _
"Sed eget massa et erat pulvinar aliquet." & @CRLF & _
"Proin congue enim eget turpis blandit, quis tempus nulla venenatis." & @CRLF & _
"Proin iaculis lorem eget elit efficitur, accumsan ornare lacus commodo." & @CRLF & _
"Vivamus mollis orci et erat dignissim rhoncus." & @CRLF & _
"Cras at arcu ac ligula interdum dictum non at nisl."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")