import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "~^";
final String string = "Lorem ipsum dolor sit amet, consectetur adipiscing elit.\n"
+ "Nullam sit amet neque vitae mi lobortis bibendum luctus at orci.\n"
+ "Maecenas sit amet felis ultrices, imperdiet nibh et, laoreet nisl.\n"
+ "Etiam nec ligula ac quam cursus rhoncus.\n"
+ "Duis ac purus id massa malesuada dapibus.\n"
+ "Quisque tempor sapien sit amet blandit interdum.\n"
+ "Sed sed libero non enim posuere pretium.\n"
+ "Cras in nisl sed magna vestibulum ultrices.\n"
+ "Sed eget neque sodales, porttitor magna nec, facilisis dolor.\n"
+ "Donec venenatis tortor nec leo viverra, non fermentum nulla pulvinar.\n"
+ "Pellentesque a nulla laoreet, euismod lectus vel, porta erat.\n"
+ "Fusce at justo in massa blandit lacinia nec maximus nulla.\n"
+ "Nam vulputate risus et sem facilisis lobortis.\n"
+ "Integer vel risus et enim tempor iaculis.\n"
+ "Pellentesque at nibh in ipsum sagittis congue.\n"
+ "Nam ullamcorper nibh sit amet felis bibendum, congue tincidunt nibh cursus.\n"
+ "Sed eget massa et erat pulvinar aliquet.\n"
+ "Proin congue enim eget turpis blandit, quis tempus nulla venenatis.\n"
+ "Proin iaculis lorem eget elit efficitur, accumsan ornare lacus commodo.\n"
+ "Vivamus mollis orci et erat dignissim rhoncus.\n"
+ "Cras at arcu ac ligula interdum dictum non at nisl.";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}