#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "([^\?]*)AUD (\d*)"
Local $sString = "The following fees and deposits are charged by the property at time of service, check-in, or check-out." & @CRLF & _
"" & @CRLF & _
"Breakfast fee: between AUD 9.95 and AUD 20.00 per person (approximately)" & @CRLF & _
"Fee for in-room wireless Internet: AUD 0.00 per night (rates may vary)" & @CRLF & _
"Fee for in-room high-speed Internet (wired): AUD 9.95 per night (rates may vary)" & @CRLF & _
"Fee for high-speed Internet (wired) in public areas: AUD 9.95 per night (rates may vary)" & @CRLF & _
"Late check-out fee: AUD 40" & @CRLF & _
"Rollaway beds are available for an additional fee" & @CRLF & _
"Onsite credit card charges are subject to a surcharge" & @CRLF & _
"The above list may not be comprehensive. Fees and deposits may not include tax and are subject to change."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")