re = /([^\?]*)AUD (\d*)/
str = 'The following fees and deposits are charged by the property at time of service, check-in, or check-out.
Breakfast fee: between AUD 9.95 and AUD 20.00 per person (approximately)
Fee for in-room wireless Internet: AUD 0.00 per night (rates may vary)
Fee for in-room high-speed Internet (wired): AUD 9.95 per night (rates may vary)
Fee for high-speed Internet (wired) in public areas: AUD 9.95 per night (rates may vary)
Late check-out fee: AUD 40
Rollaway beds are available for an additional fee
Onsite credit card charges are subject to a surcharge
The above list may not be comprehensive. Fees and deposits may not include tax and are subject to change.'
# Print the match result
str.match(re) do |match|
puts match.to_s
end