#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?:[a-zA-Zа-яА-Я]+?:\/\/)?(?:www\.)?(?:(?:\w{1,})\.){1,127}(?:\w{2,9})(?:[\w.,@?^=%&:\/~+#-]+)?"
Local $sString = "с ipsum ftp://site.ru знаменитый Неповторяющийся веке благодаря имеет слов. к никакого. https://www.site.ru шрифтов, использовать фразы основе частотой, абзацев, https://site.ru книгопечатник. интернет-страницы. вида применили https://site.ru/ ориентированных в f://site.ru/ обитателям даже http://www.site.ru/ языках по использованием смысловую написание. на на трактата, не www.site.ru https://www.site.ru/ о http://site.ru книгопечатании распространенных. к http://www.site.ru оригинального. site.ru по контента. www.site.ru/ качества http://site.ru/abc.hui?sdfsajfnasjfd=1231sa"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")