import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:[a-zA-Zа-яА-Я]+?:\\/\\/)?(?:www\\.)?(?:(?:\\w{1,})\\.){1,127}(?:\\w{2,9})(?:[\\w.,@?^=%&:\\/~+#-]+)?";
final String string = "с ipsum ftp://site.ru знаменитый Неповторяющийся веке благодаря имеет слов. к никакого. https://www.site.ru шрифтов, использовать фразы основе частотой, абзацев, https://site.ru книгопечатник. интернет-страницы. вида применили https://site.ru/ ориентированных в f://site.ru/ обитателям даже http://www.site.ru/ языках по использованием смысловую написание. на на трактата, не www.site.ru https://www.site.ru/ о http://site.ru книгопечатании распространенных. к http://www.site.ru оригинального. site.ru по контента. www.site.ru/ качества http://site.ru/abc.hui?sdfsajfnasjfd=1231sa";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}