package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`routing(\/[^\/]*)?$`)
var str = `this/is/an/awesome/test/routing/haxor1337`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}