$re = '/routing(\/[^\/]*)?$/';
$str = 'this/is/an/awesome/test/routing/haxor1337';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);