$re = '/\([^()]*\)(?:\s*\([^()]*\))*/m';
$str = '\'Sdfg dfg ldfgh (abc)\' => [\'abc\']
\'Sdfg dfg ldfgh (abc) \' => [\'abc\']
\'Sdfg dfg ldfgh (abc) (cde)\' => [\'abc\',\'cde\']
\'Sdfg dfg ldfgh (abc)(cde) (efgh)\'';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);