re = /\([^()]*\)(?:\s*\([^()]*\))*/m
str = '\'Sdfg dfg ldfgh (abc)\' => [\'abc\']
\'Sdfg dfg ldfgh (abc) \' => [\'abc\']
\'Sdfg dfg ldfgh (abc) (cde)\' => [\'abc\',\'cde\']
\'Sdfg dfg ldfgh (abc)(cde) (efgh)\''
# Print the match result
str.scan(re) do |match|
puts match.to_s
end