#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^foo-bar\s+[A-Za-z0-9-].*(?:\n.+)*"
Local $sString = "CR INFO" & @CRLF & _
"CR INFO" & @CRLF & _
"Wed Aug 17" & @CRLF & _
"" & @CRLF & _
"foo-bar name_10_Name-Child_test" & @CRLF & _
"foo-bar name_25_Name-out" & @CRLF & _
"foo-bar name_1000_Name-test_out" & @CRLF & _
"" & @CRLF & _
"CR INFO" & @CRLF & _
"CR INFO" & @CRLF & _
"Wed Aug 17" & @CRLF & _
"" & @CRLF & _
"foo-bar name_10_Name-Child_test" & @CRLF & _
"foo-bar name_25_Name-out" & @CRLF & _
"foo-bar name_1000_Name-test_out"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")