import re
regex = re.compile(r"^foo-bar\s+[A-Za-z0-9-].*(?:\n.+)*", flags=re.MULTILINE)
test_str = ("CR INFO\n"
"CR INFO\n"
"Wed Aug 17\n\n"
"foo-bar name_10_Name-Child_test\n"
"foo-bar name_25_Name-out\n"
"foo-bar name_1000_Name-test_out\n\n"
"CR INFO\n"
"CR INFO\n"
"Wed Aug 17\n\n"
"foo-bar name_10_Name-Child_test\n"
"foo-bar name_25_Name-out\n"
"foo-bar name_1000_Name-test_out")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")