re = /^(?:\s+)(flavorDimensions)(?:\s)(?:\")(\S+)(?:\")/m
str = ' flavorDimensions "mode"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end