#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?=[[:punct:]]*[[:alnum:]])(?=[[:alnum:]]*[[:punct:]])[[:alnum:][:punct:]]+"
Local $sString = "avs-tldr-02 this is a test" & @CRLF & _
"cc+asede this is a test" & @CRLF & _
"x86_64 this is a test" & @CRLF & _
"" & @CRLF & _
"this is a test avs-tldr-02 this is a test" & @CRLF & _
"this is a test cc+asede this is a test" & @CRLF & _
"this is a test x86_64 this is a test" & @CRLF & _
"" & @CRLF & _
"this is a test avs-tldr-02" & @CRLF & _
"this is a test cc+asede" & @CRLF & _
"this is a test x86_64"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")