import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?=[[:punct:]]*[[:alnum:]])(?=[[:alnum:]]*[[:punct:]])[[:alnum:][:punct:]]+";
final String string = "avs-tldr-02 this is a test\n"
+ "cc+asede this is a test\n"
+ "x86_64 this is a test\n\n"
+ "this is a test avs-tldr-02 this is a test\n"
+ "this is a test cc+asede this is a test\n"
+ "this is a test x86_64 this is a test\n\n"
+ "this is a test avs-tldr-02\n"
+ "this is a test cc+asede\n"
+ "this is a test x86_64";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}