$re = '`^/(?:[^/\r\n]+/)*(?!.*\.htm$)[^/\r\n]+$`m';
$str = '/blabla/test
/blabla/a/b/c/test
test.htm';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);