re = /^\/(?:[^\/\r\n]+\/)*(?!.*\.htm$)[^\/\r\n]+$/m
str = '/blabla/test
/blabla/a/b/c/test
test.htm'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end