package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^(?<MUELL>.*)\s+(?<vorwort>AB.+)\s+(?<zahl>\d+)\s+(?<wort>[a-zA-Z0-9_üöä]+)\s+(?<betrag>[\d.,]+)\s*$`)
var str = `AB2001482 ABC0783714, AB0783714-QR, ABBILD NRRHLAT 10 XäZ 207,25`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}