re = /^(?<MUELL>.*)\s+(?<vorwort>AB.+)\s+(?<zahl>\d+)\s+(?<wort>[a-zA-Z0-9_üöä]+)\s+(?<betrag>[\d.,]+)\s*$/
str = 'AB2001482 ABC0783714, AB0783714-QR, ABBILD NRRHLAT 10 XäZ 207,25'
# Print the match result
str.match(re) do |match|
puts match.to_s
end