using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?i)(?<![a-z])a(?![a-z])";
string substitution = @"_";
string input = @"lag(a,1) + 252*a + max(3a*2) / 5*pctrange(a,10)";
RegexOptions options = RegexOptions.IgnoreCase;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}