import Foundation
let pattern = #"(?i)(?<![a-z])a(?![a-z])"#
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = #"lag(a,1) + 252*a + max(3a*2) / 5*pctrange(a,10)"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"_"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)