$re = '/(^|[^.])[.]{2}([^.]|$)|[<>]|[[:upper:]]{4}|^[[:upper:]]+$/m';
$str = 'ABC
ABC 123
ac 34 ABCD
aaa > dddd
ccc <rrrr
No ..
Yes ...';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);