re = /(^|[^.])[.]{2}([^.]|$)|[<>]|[[:upper:]]{4}|^[[:upper:]]+$/m
str = 'ABC
ABC 123
ac 34 ABCD
aaa > dddd
ccc <rrrr
No ..
Yes ...'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end