import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?P<monitor_IO_Elem>^(?P<placeId_IO_Elem>(?:\\d{1,2}.\\w{1,2}))(?:\\ *)(?P<Id_IO_Elem>(?:S|L|P|cvM|vM|V)(?:\\d{1,2})(?:\\ *)(?:-?)(?:\\ *)(?:\\d{1,2}))(?:\\ )* (?:\\-)* (?:\\ )*(?:\\[)(?P<seqNrPin__IO_Elem>(?:\\d){1,2})(?:\\])(?:\\ *)(?P<action>(?:S|D|T|L|ON|OFF))$)(?:[\\n|\\r])?";
final String string = "T203_AL2\n"
+ "T203\n"
+ "T202 PV - slaapkamer 2\n"
+ "T202 CV - slaapkamer 2\n"
+ "1.1 S3-8 - mode 6\n"
+ "1.1 S3-8 - [1] S\n"
+ "1.1 S3-8 - [3] D\n"
+ "1.3 S5-10 - mode !DEFAULT [shift]\n"
+ "1.3 S5-10 - [2] D\n"
+ "I/O 0.4 D1_[AUTO : TM s]\n"
+ "I/O 0.4 D1_[AUTO : TM l]\n"
+ "I/O 0.4 D1_[AUTO]\n"
+ "I/O 1.1 S3-8_[6]_LED -2-\n"
+ "I/O 1.1 S3-8_[2] -1-\n"
+ "#EXTRA INFO REFERENCE for I/O 2.4 S1-4_[4] --- NAME : I/O 2.4 S1-4_[4] -4- --- INFO : K21 [08 I]\n"
+ "#EXTRA INFO REFERENCE for 2.4 S5-8 --- NAME : 2.4 S5-8 - mode DEFAULT --- INFO : 2.4 S5-8 [K22] / 4x + LED\n"
+ "2.4 S5-8 [K22] / 4x + LED\n"
+ "# HUIS CONTACT\n"
+ "HC_1.1_1.2_1.3_1.4\n\n"
+ "-1- 0.2 cvM1\n"
+ "-1- 1.6 vM2 [speed !MIN/MAX]\n"
+ "-1- 1.1 L6/L7/L8 (3 x spots - plafond)\n"
+ "-1- 1.B3 L1/L2 (grondspots voordeur)\n"
+ "-2- 2.7 V2 SSR1\n"
+ "002 - 0.2 kelder 2\n"
+ "003 - 0.3 kelder 3 [nutsvoorziening]\n"
+ "110 - 1.# SSR\n"
+ "B04 - 1.B SSR (all)\n"
+ "[F2401] K3 - Q5 : 2.B1 terras slaapkamer\n"
+ "[F2308] K3 - Q3 : 2.7 KAST V2 PWR SUPPLY SSR [Nyah-logeer-Caelan]\n"
+ "[F1612] K1 - Q1 : 1.9 WC ventilator [10.R1] R501\n"
+ "mode : 1.1 KEUKEN\n"
+ "[F1613] K2 - Q1 : 0.2 KELDER CV - [10.R09] R509 + rad lev 0 & 1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}