// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?P<monitor_IO_Elem>^(?P<placeId_IO_Elem>(?:\d{1,2}.\w{1,2}))(?:\ *)(?P<Id_IO_Elem>(?:S|L|P|cvM|vM|V)(?:\d{1,2})(?:\ *)(?:-?)(?:\ *)(?:\d{1,2}))(?:\ )* (?:\-)* (?:\ )*(?:\[)(?P<seqNrPin__IO_Elem>(?:\d){1,2})(?:\])(?:\ *)(?P<action>(?:S|D|T|L|ON|OFF))$)(?:[\n|\r])?").unwrap();
let string = "T203_AL2
T203
T202 PV - slaapkamer 2
T202 CV - slaapkamer 2
1.1 S3-8 - mode 6
1.1 S3-8 - [1] S
1.1 S3-8 - [3] D
1.3 S5-10 - mode !DEFAULT [shift]
1.3 S5-10 - [2] D
I/O 0.4 D1_[AUTO : TM s]
I/O 0.4 D1_[AUTO : TM l]
I/O 0.4 D1_[AUTO]
I/O 1.1 S3-8_[6]_LED -2-
I/O 1.1 S3-8_[2] -1-
#EXTRA INFO REFERENCE for I/O 2.4 S1-4_[4] --- NAME : I/O 2.4 S1-4_[4] -4- --- INFO : K21 [08 I]
#EXTRA INFO REFERENCE for 2.4 S5-8 --- NAME : 2.4 S5-8 - mode DEFAULT --- INFO : 2.4 S5-8 [K22] / 4x + LED
2.4 S5-8 [K22] / 4x + LED
# HUIS CONTACT
HC_1.1_1.2_1.3_1.4
-1- 0.2 cvM1
-1- 1.6 vM2 [speed !MIN/MAX]
-1- 1.1 L6/L7/L8 (3 x spots - plafond)
-1- 1.B3 L1/L2 (grondspots voordeur)
-2- 2.7 V2 SSR1
002 - 0.2 kelder 2
003 - 0.3 kelder 3 [nutsvoorziening]
110 - 1.# SSR
B04 - 1.B SSR (all)
[F2401] K3 - Q5 : 2.B1 terras slaapkamer
[F2308] K3 - Q3 : 2.7 KAST V2 PWR SUPPLY SSR [Nyah-logeer-Caelan]
[F1612] K1 - Q1 : 1.9 WC ventilator [10.R1] R501
mode : 1.1 KEUKEN
[F1613] K2 - Q1 : 0.2 KELDER CV - [10.R09] R509 + rad lev 0 & 1";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}