$re = '/((\w+)\s*(\W*(\w+)*\W*)?)*/m';
$str = 'echo "Hello"
shed --version';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);