using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"a{2,3}(?!a([^a]|$))";
string input = @"aa
aaa
aaaa
aaaaa
aaaaaa
aaaaaaa
aaaaaaaa
aaaaaaaaa
aaaaaaaaaa aaaaaaaa aaaaaa aaaaaaaaa";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}