import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "a{2,3}(?!a([^a]|$))";
final String string = "aa\n"
+ "aaa\n"
+ "aaaa\n"
+ "aaaaa\n"
+ "aaaaaa\n"
+ "aaaaaaa\n"
+ "aaaaaaaa\n"
+ "aaaaaaaaa\n"
+ "aaaaaaaaaa aaaaaaaa aaaaaa aaaaaaaaa";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}