$re = '/^(?=.{0,20}$)(?:[a-zA-Z0-9]+(?:-[a-zA-Z0-9]+)?)?$/m';
$str = '12345abc90
12345abc9012345abc90
12345abc90-12345abc9
12345abc90-12345abc90';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);