using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\s*(\d+)";
string input = @"5000 #this is 5 seconds
5000 # this is 5 seconds
5000.00 #this is 5 seconds
s5000 # this is 5 seconds";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}