// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^\s*(\d+)").unwrap();
let string = "5000 #this is 5 seconds
5000 # this is 5 seconds
5000.00 #this is 5 seconds
s5000 # this is 5 seconds";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}