using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^D([0-9]+)";
string input = @"D30500 ";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}