package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^D([0-9]+)`)
var str = `D30500 `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}