import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=ab|cd|ef|gh) *\\}\\} *\\{\\{ *(?=ab|cd|ef|gh)";
final String string = "{{ab}}{{ab}}{{ab}}{{ab}}{{ab}}{{ab}}\n"
+ "{{ab}} {{ab}} {{ab}} {{ab}} {{ab}} {{ab}}\n"
+ "machintruc {{ab}} {{cd}}\n"
+ "{{ab}} {{cd}} {{ef}} [https://truc.org truc]\n"
+ "{{ab}}{{ cd }}{{ ef }} {{ gh }} {{ gh }}{{lien web|url=tr.uc}}\n"
+ "{{mr}} Trucmuche\n";
final String subst = "|";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}