$re = '/(?<=ab|cd|ef|gh) *}} *{{ *(?=ab|cd|ef|gh)/m';
$str = '{{ab}}{{ab}}{{ab}}{{ab}}{{ab}}{{ab}}
{{ab}} {{ab}} {{ab}} {{ab}} {{ab}} {{ab}}
machintruc {{ab}} {{cd}}
{{ab}} {{cd}} {{ef}} [https://truc.org truc]
{{ab}}{{ cd }}{{ ef }} {{ gh }} {{ gh }}{{lien web|url=tr.uc}}
{{mr}} Trucmuche
';
$subst = "|";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;