$re = '/e(?=\S)/m';
$str = 'I want to remove all instances of a character from a string except where that character is followed by any form or whitespace. I haven\'t written unit tests yet but it seems like the code below achieves what I want (possibly forgetting an edge case or two which is ok for now). It feels pretty clunky though. Can anyone suggest an improvement?';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);