re = /e(?=\S)/m
str = 'I want to remove all instances of a character from a string except where that character is followed by any form or whitespace. I haven\'t written unit tests yet but it seems like the code below achieves what I want (possibly forgetting an edge case or two which is ok for now). It feels pretty clunky though. Can anyone suggest an improvement?'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end