package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[0-9]+(.*(Minutes|Seconds|Hours|Days))+$`)
var str = `38 Seconds`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}