$re = '/\s+(?=[^{}]*\})/';
$str = '{ ab c } This is a Demo { x y z }';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;