import re
regex = re.compile(r"\s+(?=[^{}]*\})")
test_str = "{ ab c } This is a Demo { x y z }"
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)