import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?s)\\s*\\[[^\\[\\]]*\\](?:(?:(?!\\[[^\\[\\]]*\\]).)+\\[[^\\[\\]]*\\])*\\s*";
final String string = "$ cat smb\n"
+ "Hi this is my config file.\n"
+ "Please dont delete it\n\n"
+ "[homes]\n"
+ " browseable = No\n"
+ " comment = Your Home\n"
+ " create mode = 0640\n"
+ " csc policy = disable\n"
+ " directory mask = 0750\n"
+ " public = No\n"
+ " writeable = Yes\n\n"
+ "[proj]\n"
+ " browseable = Yes\n"
+ " comment = Project directories\n"
+ " csc policy = disable\n"
+ " path = /proj\n"
+ " public = No\n"
+ " writeable = Yes\n\n"
+ " []\n\n"
+ "This last second line.\n"
+ "End of the line.";
final String subst = "\\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceFirst(subst);
System.out.println("Substitution result: " + result);
}
}