const regex = new RegExp('(?s)\\s*\\[[^\\[\\]]*\\](?:(?:(?!\\[[^\\[\\]]*\\]).)+\\[[^\\[\\]]*\\])*\\s*', '')
const str = `\$ cat smb
Hi this is my config file.
Please dont delete it
[homes]
browseable = No
comment = Your Home
create mode = 0640
csc policy = disable
directory mask = 0750
public = No
writeable = Yes
[proj]
browseable = Yes
comment = Project directories
csc policy = disable
path = /proj
public = No
writeable = Yes
[]
This last second line.
End of the line.`;
const subst = `\n`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);