using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:http(?:s)?:\/\/)?(?:www\.)?(?:youtu\.be\/|youtube\.com\/(?:(?:watch)?\?(?:.*&)?v(?:i)?=|(?:embed|v|vi|user)\/))([^\?&\""'<> #]+)";
string input = @"<p>asdad youtube
</p><div><br />
youtube: https://www.youtube.com/watch?v=HAKp1hyeaFU
</div>
<div>daadsads</div>
<div>https://www.youtube.com/embed/HAKp1hyeaFU</div>
<div>https://www.youtube.com/embed/HAKp1hyeaFU</div>
<div>https://www.youtube.com/embed/HAKp1hyeaFU</div>
<div>https://youtu.be/j2uN5Jeblf4</div>";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}