package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)(?:http(?:s)?:\/\/)?(?:www\.)?(?:youtu\.be\/|youtube\.com\/(?:(?:watch)?\?(?:.*&)?v(?:i)?=|(?:embed|v|vi|user)\/))([^\?&\"'<> #]+)`)
var str = `<p>asdad youtube
</p><div><br />
youtube: https://www.youtube.com/watch?v=HAKp1hyeaFU
</div>
<div>daadsads</div>
<div>https://www.youtube.com/embed/HAKp1hyeaFU</div>
<div>https://www.youtube.com/embed/HAKp1hyeaFU</div>
<div>https://www.youtube.com/embed/HAKp1hyeaFU</div>
<div>https://youtu.be/j2uN5Jeblf4</div>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}