package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[^\p{Z}\p{L}.;:?!]`)
var str = `abcd 123 kjd ¤%/(" .?:!`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}