package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^http(s?)\:\/\/[^\s\/$.?#*]+\.[^\s\/$.?#*]+(\.[^\s\/$.?#*]+)*$`)
var str = `https://example.org
http://a.a
http://123.123.123.123:8074`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}