package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\b(?:http|ws)s?:\/\/\S*[^\s."]`)
var str = `"Hello everyone! please join us at: https://oursite.com/. and
please visit our courses websites: http://courseone.com.eu & http://coursetwo.us.
For prod use websocket with this url: wss://localhost:4500/websocket/. and
for staging use this url: ws://localhost:4500/websocket".`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}