re = /\b(?:http|ws)s?:\/\/\S*[^\s."]/m
str = '"Hello everyone! please join us at: https://oursite.com/. and
please visit our courses websites: http://courseone.com.eu & http://coursetwo.us.
For prod use websocket with this url: wss://localhost:4500/websocket/. and
for staging use this url: ws://localhost:4500/websocket".'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end